import Foundation
let pattern = ##"""
(?<function>\w+) \( # Matches function name
(?<parameters> # Simple param type.
(?<data> # Simple data type: inner function or word (keep this order!).
(?R) | # Or recursive this Regexp to match inner functions.
\w+ # Matches a simple word.
)
( # Match additional parameters:
\s*,\s* # Match comma, but skip spaces.
\g<parameters> # Recurse additional parameters.
)* # Zero or more additional parameters.
)? # Parameters are optional
\)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
color()
color(a)
color(a, a)
color(a())
color(a(b()))
color(a, a())
color(a, a(), b)
color(a(), b)
color(a, b, c(d, e(f, g()), h))
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)