const regex = /^(?=.{1,60}$)[a-zA-Z0-9_.-]*foo\.bar[a-zA-Z0-9_.-]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{1,60}$)[a-zA-Z0-9_.-]*foo\\.bar[a-zA-Z0-9_.-]*$', 'gm')
const str = `aGreatStringWithfoo.barInIt1111
aBadStringWithoutTheSubstringInIt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}