re = /^(?=.{1,60}$)[a-zA-Z0-9_.-]*foo\.bar[a-zA-Z0-9_.-]*$/m
str = 'aGreatStringWithfoo.barInIt1111
aBadStringWithoutTheSubstringInIt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end