$re = '/^(?=.{1,60}$)[a-zA-Z0-9_.-]*foo\.bar[a-zA-Z0-9_.-]*$/m';
$str = 'aGreatStringWithfoo.barInIt1111
aBadStringWithoutTheSubstringInIt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);