using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a[^>]*>(?:[a-zA-Z0-9\s'\-\.,]|(?:<(.*)>.*<\/\1>))*<\/a>(*SKIP)(*FAIL)|\b(match)\b(?=[^>]*(?:<|$))";
string input = @"match me
<a href=""#"">Don't Match Me <span>web</span></a>
match me sdswyyw match
<a href=""#"">Don't Match Me</a>match me<a href=""#"">Don't Match Me</a> dhfjdhfjdhfj<a>match</a><b>match</b>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}