use strict;
my $str = 'match me
<a href="#">Don\'t Match Me <span>web</span></a>
match me sdswyyw match
<a href="#">Don\'t Match Me</a>match me<a href="#">Don\'t Match Me</a> dhfjdhfjdhfj<a>match</a><b>match</b>';
my $regex = qr/<a[^>]*>(?:[a-zA-Z0-9\s'\-\.,]|(?:<(.*)>.*<\/\1>))*<\/a>(*SKIP)(*FAIL)|\b(match)\b(?=[^>]*(?:<|$))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}