$re = '/<a[^>]*>(?:[a-zA-Z0-9\s\'\-\.,]|(?:<(.*)>.*<\/\1>))*<\/a>(*SKIP)(*FAIL)|\b(match)\b(?=[^>]*(?:<|$))/';
$str = 'match me
<a href="#">Don\'t Match Me <span>web</span></a>
match me sdswyyw match
<a href="#">Don\'t Match Me</a>match me<a href="#">Don\'t Match Me</a> dhfjdhfjdhfj<a>match</a><b>match</b>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);