using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(\\?\""(\d{1,3}-?\d{1,3}?)[,|\s](.*,?.*?,?.*?\s)([A-Z0-9]{3,4}\s[A-Z0-9]{3})\\?\""?,([0-9]{1,3}.[0-9]{3,9}),([-|+|\s]?[0-9]{1,3}.[0-9]{3,9})\)";
string substitution = @"$1,$2 - $3 - [$4],[$5]";
string input = @"(""197 STATION ROAD, KINGS HEATH, BIRMINGHAM B14 7TB"",52.434992,-1.8990985)
(\""9-12, BOW STREET, LONDON, WC2E 7AH\"",51.5136001,-0.1229336)
(\""14 STATION ROAD, LONDON SE20 7BQ\"",51.41886,-0.0545021)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}