# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\(\\?\"(\d{1,3}-?\d{1,3}?)[,|\s](.*,?.*?,?.*?\s)([A-Z0-9]{3,4}\s[A-Z0-9]{3})\\?\"?,([0-9]{1,3}.[0-9]{3,9}),([-|+|\s]?[0-9]{1,3}.[0-9]{3,9})\)"
test_str = ("(\"197 STATION ROAD, KINGS HEATH, BIRMINGHAM B14 7TB\",52.434992,-1.8990985)\n"
"(\\\"9-12, BOW STREET, LONDON, WC2E 7AH\\\",51.5136001,-0.1229336)\n"
"(\\\"14 STATION ROAD, LONDON SE20 7BQ\\\",51.41886,-0.0545021)")
subst = "$1,$2 - $3 - [$4],[$5]"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.