import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(\\\\?\\\"(\\d{1,3}-?\\d{1,3}?)[,|\\s](.*,?.*?,?.*?\\s)([A-Z0-9]{3,4}\\s[A-Z0-9]{3})\\\\?\\\"?,([0-9]{1,3}.[0-9]{3,9}),([-|+|\\s]?[0-9]{1,3}.[0-9]{3,9})\\)";
final String string = "(\"197 STATION ROAD, KINGS HEATH, BIRMINGHAM B14 7TB\",52.434992,-1.8990985)\n"
+ "(\\\"9-12, BOW STREET, LONDON, WC2E 7AH\\\",51.5136001,-0.1229336)\n"
+ "(\\\"14 STATION ROAD, LONDON SE20 7BQ\\\",51.41886,-0.0545021)";
final String subst = "$1,$2 - $3 - [$4],[$5]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}