#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?=[\d. -]{11}\b)\d{1,}([. -])\d{1,}\1\d{1,}\b"
Local $sString = "222-33-4444" & @CRLF & _
"333.77-8888" & @CRLF & _
"111 77.9998" & @CRLF & _
"111 22 3333" & @CRLF & _
"11-222222-9" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")