using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?=[\d. -]{11}\b)\d{1,}([. -])\d{1,}\1\d{1,}\b";
string input = @"222-33-4444
333.77-8888
111 77.9998
111 22 3333
11-222222-9
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}