re = /\b(?=[\d. -]{11}\b)\d{1,}([. -])\d{1,}\1\d{1,}\b/m
str = '222-33-4444
333.77-8888
111 77.9998
111 22 3333
11-222222-9
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end