const regex = /(?xms)
( # group 1
\b explore:
[^\S\r\n]* # optional horizontal whitespaces
[^\n{]* # possible content of the same line
# followed by two possibilities
(?: # the content stops at the end of the line with a ;
; [^\S\r\n]* $
| # or it contains curly brackets and spreads over eventually multiple lines
( # group 2
{
[^{}"]*+ # all that isn't curly brackets nor double quotes
(?:
" [^\\"]*+ (?: \\. [^\\"]* )*+ " # contents between quotes
[^{}"]*
|
(?2) # nested curly brackets, recursion in the group 2
[^{}"]*
)*+
}
)
)
)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?xms)
( # group 1
\\b explore:
[^\\S\\r\\n]* # optional horizontal whitespaces
[^\\n{]* # possible content of the same line
# followed by two possibilities
(?: # the content stops at the end of the line with a ;
; [^\\S\\r\\n]* $
| # or it contains curly brackets and spreads over eventually multiple lines
( # group 2
{
[^{}"]*+ # all that isn\'t curly brackets nor double quotes
(?:
" [^\\\\"]*+ (?: \\\\. [^\\\\"]* )*+ " # contents between quotes
[^{}"]*
|
(?2) # nested curly brackets, recursion in the group 2
[^{}"]*
)*+
}
)
)
)', 'g')
const str = `explore: character_balance {}
explore: tower_ends {
label: "Tower Results"
join: activity_type {
relationship: many_to_one
type: inner
sql_on: \${activity_type.activity_name}=\${wba_fact_activity.activity_name} ;;
}
}
explore: seven11_core_session_start {}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}