// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?xms)
( # group 1
\b explore:
[^\S\r\n]* # optional horizontal whitespaces
[^\n{]* # possible content of the same line
# followed by two possibilities
(?: # the content stops at the end of the line with a ;
; [^\S\r\n]* $
| # or it contains curly brackets and spreads over eventually multiple lines
( # group 2
{
[^{}"]*+ # all that isn't curly brackets nor double quotes
(?:
" [^\\"]*+ (?: \\. [^\\"]* )*+ " # contents between quotes
[^{}"]*
|
(?2) # nested curly brackets, recursion in the group 2
[^{}"]*
)*+
}
)
)
)"#).unwrap();
let string = "explore: character_balance {}
explore: tower_ends {
label: \"Tower Results\"
join: activity_type {
relationship: many_to_one
type: inner
sql_on: ${activity_type.activity_name}=${wba_fact_activity.activity_name} ;;
}
}
explore: seven11_core_session_start {}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}