import Foundation
let pattern = ##"""
(?xms)
( # group 1
\b explore:
[^\S\r\n]* # optional horizontal whitespaces
[^\n{]* # possible content of the same line
# followed by two possibilities
(?: # the content stops at the end of the line with a ;
; [^\S\r\n]* $
| # or it contains curly brackets and spreads over eventually multiple lines
( # group 2
{
[^{}"]*+ # all that isn't curly brackets nor double quotes
(?:
" [^\\"]*+ (?: \\. [^\\"]* )*+ " # contents between quotes
[^{}"]*
|
(?2) # nested curly brackets, recursion in the group 2
[^{}"]*
)*+
}
)
)
)
"""##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
explore: character_balance {}
explore: tower_ends {
label: "Tower Results"
join: activity_type {
relationship: many_to_one
type: inner
sql_on: ${activity_type.activity_name}=${wba_fact_activity.activity_name} ;;
}
}
explore: seven11_core_session_start {}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)