re = /url\((.*?)\)/m
str = 'style=\'background-image: url(MATCH TARGET); background-size: cover; background-position: center; background-repeat: no-repeat;\'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end