use strict;
my $str = 'This is "My Page"';
my $regex = qr/[^\w ]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";