$re = '/[^\w ]+/m';
$str = 'This is "My Page"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;