const regex = new RegExp('(^\\D*\\d+\\D*)(\\w*\\s+)(\\d*\\s+)(\\d*\\s+)(\\d*\\s+\\d*\\s+\\d*\\s+\\d*\\s+\\d*\\s+)(\\w+)', 'gm')
const str = ` 2555 texttext 0 100 100 0 0 0 0 lowness 0
2557 texttext 10 650 660 0 0 0 0 lowness 0
2564 texttext 0 30 30 0 0 0 0 lowness 0
2566 texttext 0 0 0 0 0 0 0 lowness 0
2567 texttext 10 70 80 0 0 0 0 lowness 0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}