using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Project Name:\[(.*?)\]\s+(.*)";
string input = @"Project Name:[xyz 28912] omiture";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}