$re = '/Project Name:\[(.*?)\]\s+(.*)/s';
$str = 'Project Name:[xyz 28912] omiture';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);