package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)Project Name:\[(.*?)\]\s+(.*)`)
var str = `Project Name:[xyz 28912] omiture`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}