const regex = /\b(?!(?:a|the)\b)([a-z]+) pro/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!(?:a|the)\\b)([a-z]+) pro', 'gm')
const str = `"a pro linebacker","a pro review","the pro not playing like a pro","going pro","staying pro"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}