$re = '/\b(?!(?:a|the)\b)([a-z]+) pro/m';
$str = '"a pro linebacker","a pro review","the pro not playing like a pro","going pro","staying pro"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);