re = /\b(?!(?:a|the)\b)([a-z]+) pro/m
str = '"a pro linebacker","a pro review","the pro not playing like a pro","going pro","staying pro"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end