package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\[.*\])(.*)(\(\w*\))(.*)`)
var str = `[09/May/2022:11:04:05 +0000] NSMMReplicationPlugin - process_postop: Failed to apply update (6278e86f000627440000) error (-1). Aborting replication session(conn=5361 op=6)`
var substitution = "\2\4"
fmt.Println(re.ReplaceAllString(str, substitution))
}