# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d(?!x)|[^0-9x]|(?<!\d)x//gm;t' <<< "u2x4m5x7"