const regex = /\d(?!x)|[^0-9x]|(?<!\d)x/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d(?!x)|[^0-9x]|(?<!\\d)x', 'gm')
const str = `u2x4m5x7`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);