$re = '/\d(?!x)|[^0-9x]|(?<!\d)x/m';
$str = 'u2x4m5x7';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;