re = /(
\[ (?=\h*x)
|
(?<=x) \h* \K \]
)/mx
str = 'Yes: [x]
Yes: [ x]
Yes: [x ]
Yes: [ x ]
No: [
No: ]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end