#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*(\d *){10}).*"
Local $sString = "abc1234567890efg" & @CRLF & _
"abc123456789efg" & @CRLF & _
"abc1234567890efg" & @CRLF & _
"abc1234567890" & @CRLF & _
"abc123" & @CRLF & _
"1234567890" & @CRLF & _
"123456789" & @CRLF & _
"123 456 789 123" & @CRLF & _
"abc1234567890" & @CRLF & _
"1234567890efg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")