re = /^(?!.*(\d *){10}).*/m
str = 'abc1234567890efg
abc123456789efg
abc1234567890efg
abc1234567890
abc123
1234567890
123456789
123 456 789 123
abc1234567890
1234567890efg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end