using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*(\d *){10}).*";
string input = @"abc1234567890efg
abc123456789efg
abc1234567890efg
abc1234567890
abc123
1234567890
123456789
123 456 789 123
abc1234567890
1234567890efg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}