package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Discussion:\n[a-zA-Z]{1,3}\s+\d{2}\/\d{2}\/\d{4}.*\n+(?<content>(?:.*\n)*)ABC Company Australia \| XYZ St \| Sydney NSW 2000`)
var str = `Discussion:
Tue 26/04/2022/2:48 PM UTC+10/ ABC User-
TEST
description - this should be
logged as a comment. --- This is
the part I need
ABC Company Australia | XYZ St | Sydney NSW 2000
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}