re = /Discussion:\n[a-zA-Z]{1,3}\s+\d{2}\/\d{2}\/\d{4}.*\n+(?<content>(?:.*\n)*)ABC Company Australia \| XYZ St \| Sydney NSW 2000/
str = 'Discussion:
Tue 26/04/2022/2:48 PM UTC+10/ ABC User-
TEST
description - this should be
logged as a comment. --- This is
the part I need
ABC Company Australia | XYZ St | Sydney NSW 2000
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end