using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(#include ""C:/Users.*\.h"")$";
string input = @"#include ""C:/Users/{various paths to different headerfiles}.h>
#include ""C:/Users/{various paths to different headerfiles}.h""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}