package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(#include "C:/Users.*\.h")$`)
var str = `#include "C:/Users/{various paths to different headerfiles}.h>
#include "C:/Users/{various paths to different headerfiles}.h"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}