import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=All User Profile\\s+:\\s).+";
final String string = "Profiles on interface Wi-Fi:\n\n"
+ "Group policy profiles (read only)\n"
+ "---------------------------------\n"
+ " <None>\n\n"
+ "User profiles\n"
+ "-------------\n"
+ " All User Profile : ModemN1\n"
+ " All User Profile : IsntModem\n\n"
+ "Profiles on interface Wi-Fi:\n\n"
+ "Group policy profiles (read only)\n"
+ "---------------------------------\n"
+ " <None>\n\n"
+ "User profiles\n"
+ "-------------\n"
+ " All User Profile : somethingElse\n"
+ " All User Profile : another wlan";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}