re = /(?<=All User Profile\s+:\s).+/m
str = 'Profiles on interface Wi-Fi:
Group policy profiles (read only)
---------------------------------
<None>
User profiles
-------------
All User Profile : ModemN1
All User Profile : IsntModem
Profiles on interface Wi-Fi:
Group policy profiles (read only)
---------------------------------
<None>
User profiles
-------------
All User Profile : somethingElse
All User Profile : another wlan'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end