using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=utm_campaign=\w*)[^_]+";
string input = @"www.sitename.com.au/landing-page?utm_source=facebook&utm_medium=social&utm_campaign=fruit_apples_kids";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}