const regex = /(?<=utm_campaign=\w*)[^_]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=utm_campaign=\\w*)[^_]+', 'g')
const str = `www.sitename.com.au/landing-page?utm_source=facebook&utm_medium=social&utm_campaign=fruit_apples_kids`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}