package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[ \n\t]*([a-zA-Z][a-zA-Z0-9_]*)[ \n\t]+((char)[ \n\t]*\[[ \n\t]*([0-9]+)[ \t\n]*\]|(char)|(int)|(double)|(bool)|(blob)[ \n\t]*\[[ \n\t]*([0-9]+)[ \t\n]*\])[ \n\t]*`)
var str = `cpf char[12]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}