import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[ \\n\\t]*([a-zA-Z][a-zA-Z0-9_]*)[ \\n\\t]+((char)[ \\n\\t]*\\[[ \\n\\t]*([0-9]+)[ \\t\\n]*\\]|(char)|(int)|(double)|(bool)|(blob)[ \\n\\t]*\\[[ \\n\\t]*([0-9]+)[ \\t\\n]*\\])[ \\n\\t]*";
final String string = "cpf char[12]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}