#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?:^|\|\|)(?:(?!\|\|)(?!").|"(?:[^"\\]|\\.)*")*"
Local $sString = "abc | efg || $something("arg\" 1", "arg 2||(a|b)") || 123" & @CRLF & _
"env("test") || env("ano\\ther")"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")