re = /(?:^|\|\|)(?:(?!\|\|)(?!").|"(?:[^"\\]|\\.)*")*/mx
str = 'abc | efg || $something("arg\\" 1", "arg 2||(a|b)") || 123
env("test") || env("ano\\\\ther")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end