using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|\|\|)(?:(?!\|\|)(?!"").|""(?:[^""\\]|\\.)*"")*";
string input = @"abc | efg || $something(""arg\"" 1"", ""arg 2||(a|b)"") || 123
env(""test"") || env(""ano\\ther"")";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}