import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img.*?src=(?:\\'|\")?data:image\\/(?:png|jpeg|jpg|gif);base64,([^\\'\"\\s>]+)";
final String string = "Hello, hello, hello <img src=\"data:image/png;base64,lkqhdklqbhjdkhlqjshdljhqsdhqslkjhdlqhdjlkqshdjlkhsq\"> hello hello <img src=\"data:image/png;base64,ljshqflhsqjlkfhjqsfjlkqhs\"> jhfqflsqjk\n\n"
+ "more stuff. test test test <img src=data:image/png;base64,fhiewgjiewoghiewaghieoaieohigeoaehgieoaheigo alt=\"test?\"> and more.\n\n"
+ "<img src=\"http://example.com/image.png\"> and more <img alt=\"test\" src='data:image/jpg;base64,afejwioagjeoiwajgeiowjgoiewjgoejwgiewjgoewa' class=\"img border\"> finally.";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}