re = /<img.*?src=(?:\'|")?data:image\/(?:png|jpeg|jpg|gif);base64,([^\'"\s>]+)/i
str = 'Hello, hello, hello <img src="data:image/png;base64,lkqhdklqbhjdkhlqjshdljhqsdhqslkjhdlqhdjlkqshdjlkhsq"> hello hello <img src="data:image/png;base64,ljshqflhsqjlkfhjqsfjlkqhs"> jhfqflsqjk
more stuff. test test test <img src=data:image/png;base64,fhiewgjiewoghiewaghieoaieohigeoaehgieoaheigo alt="test?"> and more.
<img src="http://example.com/image.png"> and more <img alt="test" src=\'data:image/jpg;base64,afejwioagjeoiwajgeiowjgoiewjgoejwgiewjgoewa\' class="img border"> finally.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end