const regex = /<img.*?src=(?:\'|")?data:image\/(?:png|jpeg|jpg|gif);base64,([^\'"\s>]+)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img.*?src=(?:\\\'|")?data:image\\\/(?:png|jpeg|jpg|gif);base64,([^\\\'"\\s>]+)', 'ig')
const str = `Hello, hello, hello <img src="data:image/png;base64,lkqhdklqbhjdkhlqjshdljhqsdhqslkjhdlqhdjlkqshdjlkhsq"> hello hello <img src="data:image/png;base64,ljshqflhsqjlkfhjqsfjlkqhs"> jhfqflsqjk
more stuff. test test test <img src=data:image/png;base64,fhiewgjiewoghiewaghieoaieohigeoaehgieoaheigo alt="test?"> and more.
<img src="http://example.com/image.png"> and more <img alt="test" src='data:image/jpg;base64,afejwioagjeoiwajgeiowjgoiewjgoejwgiewjgoewa' class="img border"> finally.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}